Pidgin habillé par Adium

Vous aimez l’apparence des conversations dans Empathy mais vous le trouvez pas encore assez mature? Vous aimez la flexibilité de pidgin mais vous trouvez qu’il manque un petit plus dans son look? Ce qui va suivre est fait pour vous!

Je vous propose, d’installer Adium dans pidgin grâce à quelques bidouilles: D

Commençons par installer les paquets (en prenant soin de rajouter le dépôt) qui nous permettrons d’exécuter correctement le script:

sudo add-apt-repository ppa:webkit-team/ppa
sudo apt-get update
sudo apt-get install -y pidgin libnotify-bin libpurple-dev pidgin-dev libwebkit-dev bzr wget

Une fois ceci fait, téléchargez le script ci-dessous et lancez le afin qu’il télécharge Adium et qu’il l’installe correctement:

Script d’installation « Pidgin avec Adium »

Il ne vous reste plu qu’à activer, dans pidgin, l’extension (via outils > plugins) « Webkit message styles ».

BONUS: Je vous propose, ci-dessous un thème que j’ai fait rien que pour vous (et pour moi :p ) à décompresser dans votre dossier home > .purple > message_styles.

Thème Wilibre pour Adium

Commentaires:

  1. Salut à toi Wilibre, voici un petit truc bien sympa qui va egayer un peu ma messagerie instantanée. Je l’essayerais un peu plus tard, cause congés.
    A plus tard. Bonne Vacances.

  2. Salut GG,

    C’est pas forcément tres simple à installer mais le jeu en vaut la chandelle!

  3. Salut,
    j’ai ces messages d’erreurs au moment ou je lance le scrip adium.sh, une idée?

    ./Pidgin_avec_Adium.sh: ligne 5 : [: !-d : opérateur unaire attendu
    ./Pidgin_avec_Adium.sh: ligne 10 : cd: /home/kaz/bin/: Aucun fichier ou dossier de ce type
    2010-11-23 21:15:56 URL:http://dl.dropbox.com/u/422036/adium-pidgin [4452/4452] -> « adium-pidgin » [1]
    You have not informed bzr of your Launchpad ID, and you must do this to
    write to Launchpad or access private data. See « bzr help launchpad-login ».
    Branched 70 revision(s).
    gcc -c webkit.c -o webkit.o -O2 -Wall -fpic -g -I/usr/local/include -I/usr/local/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/lib/gtk-2.0/include -I/usr/include -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include `pkg-config –cflags gtk+-2.0 pidgin` `pkg-config –cflags webkit-1.0`
    gcc -c prefs.c -o prefs.o -O2 -Wall -fpic -g -I/usr/local/include -I/usr/local/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/atk-1.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/lib/gtk-2.0/include -I/usr/include -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include `pkg-config –cflags gtk+-2.0 pidgin` `pkg-config –cflags webkit-1.0`
    gcc webkit.o prefs.o -shared `pkg-config –libs webkit-1.0` -o webkit.so
    cp: impossible de créer le fichier standard «/home/kaz/.purple/plugins/webkit.so»: Aucun fichier ou dossier de ce type

  4. Salut fabian,

    J’ai le même message quand je lance le script dans un terminal via « sh /le_chemin_vers_mon_fichier/> Pidgin_avec_Adium.sh ». En revanche, j’ai aucun message d’insulte quand je me contente de le glisser dans un terminal.

    J’espère t’avoir aider.

  5. Même en faisant glisser, ça ne fonctionne pas chez moi… même messages d’erreur que Fabian.

    y’a pas moyen de corriger le script ?

  6. Ah ben en plus, le repo bzr ne fonctionne plus, pas moyen d’avoir webkit.so

  7. Effectivement, il va falloir dépanner le script ou trouver une nouvelle solution…

    Avis aux contributions!

Laissez un commentaire


« »